How to use use table with column names having reserved in Diyotta data flow?

I have column name as order in my mssql source and want to load this table in snowflake but the execution is failing as select sql created for mssql source is not handling the reserved word correctly.
Show how create as target with snowflake needs to be handled also
Beginner Asked on September 18, 2019 in Snowflake Process Platform.
Add Comment
1 Answer(s)

When mssql source has reserve keywords, Diyotta provides as option known Allow Strict Names.

Scenario:

1.MSSQL source has ORDER has reserved Keyword in the list of columns present in the table.

2. Then move to the Data object –> properties and select Strict Names as YES.

RE: How to use use table with column names having reserved in Diyotta data flow?

3. Drag this data object in the snowflake dataflow and the same option would be reflected in the source instance also source –> properties with Strict Names as YES.

4. Move to the source instance and change the alias column value to some meaning full name for the reserved keyword column.

RE: How to use use table with column names having reserved in Diyotta data flow?

5. The select query/Tform table statement  which runs on the source table is populated as below when Strict Names option is checked as YES.

RE: How to use use table with column names having reserved in Diyotta data flow?

RE: How to use use table with column names having reserved in Diyotta data flow?

Create as Target [Snowflake].

1.select the mssql source and select the create as Target option.

2.Then goto the parent object [Dataobject] of snowflake target.

3. Then manually remove the alias name added to the column which -(underscore) in our case

RE: How to use use table with column names having reserved in Diyotta data flow?

4. Then move to the Data object –> properties and select Strict Names as YES and save it.

5. Create table in target looks as shown below.

RE: How to use use table with column names having reserved in Diyotta data flow?

Expert Answered on September 23, 2019.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.